<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
  <meta name="owner" content="Entravision Communications" />
  <meta name="copyright" content="Entravision Communications" />
  <meta name="Reply-to" content="anthonyacosta@entravision.com" />
  <meta name="mobile-web-app-capable" content="yes">
<meta name="msvalidate.01" content="6ABF904B6F92C4DF0CDF97FC8C9725E7" />
<meta name="viewport" content="width=device-width, initial-scale=1">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="http://foxrio2.com/xmlrpc.php" />
		<!--[if lt IE 9]>
	<script data-cfasync="false" src="http://foxrio2.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
		<title>Three Die in Collision in Raymondville; May Be Alcohol Related | KFXV The Valley&#039;s Fox News</title>
<!-- Jetpack Site Verification Tags -->
<meta name="msvalidate.01" content="6ABF904B6F92C4DF0CDF97FC8C9725E7" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KFXV The Valley&#039;s Fox News &raquo; Feed" href="http://foxrio2.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KFXV The Valley&#039;s Fox News &raquo; Comments Feed" href="http://foxrio2.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KFXV The Valley&#039;s Fox News &raquo; Three Die in Collision in Raymondville; May Be Alcohol Related Comments Feed" href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/foxrio2.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Extra Child v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='fpw_styles_css-css'  href='http://foxrio2.com/wp-content/plugins/feature-a-page-widget/css/fpw_styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://foxrio2.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://foxrio2.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-reset-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-style-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar/styles/light.css' type='text/css' media='all' />
<link rel='stylesheet' id='mcs.base-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar-pro/styles/base.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc-datepicker-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar/js/pickadate/themes/default.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc-datepicker-date-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar/js/pickadate/themes/default.date.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc-datepicker-time-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar/js/pickadate/themes/default.time.css' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-submissions-style-css'  href='http://foxrio2.com/wp-content/plugins/my-calendar-pro/css/mcs-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='upg-style-css'  href='http://foxrio2.com/wp-content/plugins/wp-upg/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='http://foxrio2.com/wp-content/plugins/wp-upg/css/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='odude-pure-css'  href='http://foxrio2.com/wp-content/plugins/wp-upg/css/pure-min.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='odude-pure-grid-css'  href='http://foxrio2.com/wp-content/plugins/wp-upg/css/grids-responsive-min.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-pages-shortcode-css-css'  href='http://foxrio2.com/wp-content/plugins/child-pages-shortcode/css/child-pages-shortcode.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='http://foxrio2.com/wp-content/themes/Extra/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='extra-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='http://foxrio2.com/wp-content/themes/Extra-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-css-css'  href='http://foxrio2.com/wp-content/themes/Extra/epanel/shortcodes/css/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='http://foxrio2.com/wp-content/themes/Extra/includes/builder/styles/magnific_popup.css' type='text/css' media='all' />
<link rel='stylesheet' id='video-js-css'  href='http://foxrio2.com/wp-content/plugins/video-embed-thumbnail-generator/video-js/video-js.css' type='text/css' media='all' />
<link rel='stylesheet' id='video-js-kg-skin-css'  href='http://foxrio2.com/wp-content/plugins/video-embed-thumbnail-generator/video-js/kg-video-js-skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='kgvid_video_styles-css'  href='http://foxrio2.com/wp-content/plugins/video-embed-thumbnail-generator/css/kgvid_styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://foxrio2.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/wp-upg/js/common.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/child-pages-shortcode/js/child-pages-shortcode.min.js'></script>
<link rel='https://api.w.org/' href='http://foxrio2.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://foxrio2.com/xmlrpc.php?rsd" />
<link rel='prev' title='Mexico Ranks Second Deadliest Country in World; Experts Weigh In' href='http://foxrio2.com/mexico-ranks-second-deadliest-country-in-world-experts-weigh-in/' />
<link rel='next' title='Harlingen Woman Killed in Hit and Run' href='http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://wp.me/p1QYwx-du6' />
<link rel="alternate" type="application/json+oembed" href="http://foxrio2.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffoxrio2.com%2Fthree-die-in-collision-in-raymondville-may-be-alcohol-related%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://foxrio2.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffoxrio2.com%2Fthree-die-in-collision-in-raymondville-may-be-alcohol-related%2F&#038;format=xml" />

<style type="text/css">
<!--
/* Styles by My Calendar - Joseph C Dolson http://www.joedolson.com/ */

.mc-main .mc_general .event-title, .mc-main .mc_general .event-title a { background: #6b6b6b; color: #ffffff; }
.mc-main .mc_general .event-title a:hover, .mc-main .mc_general .event-title a:focus { background: #383838;}
.mc-main .mc_concert .event-title, .mc-main .mc_concert .event-title a { background: #dd3333; color: #ffffff; }
.mc-main .mc_concert .event-title a:hover, .mc-main .mc_concert .event-title a:focus { background: #aa0000;}
.mc-main .mc_fairconvention .event-title, .mc-main .mc_fairconvention .event-title a { background: #dd9933; color: #000000; }
.mc-main .mc_fairconvention .event-title a:hover, .mc-main .mc_fairconvention .event-title a:focus { background: #ffcc66;}
.mc-main .mc_art-exhibition .event-title, .mc-main .mc_art-exhibition .event-title a { background: #8224e3; color: #ffffff; }
.mc-main .mc_art-exhibition .event-title a:hover, .mc-main .mc_art-exhibition .event-title a:focus { background: #4f00b0;}
.mc-main .mc_athletic-event .event-title, .mc-main .mc_athletic-event .event-title a { background: #81d742; color: #000000; }
.mc-main .mc_athletic-event .event-title a:hover, .mc-main .mc_athletic-event .event-title a:focus { background: #b4ff75;}
.mc-main .mc_theatre .event-title, .mc-main .mc_theatre .event-title a { background: #1e73be; color: #ffffff; }
.mc-main .mc_theatre .event-title a:hover, .mc-main .mc_theatre .event-title a:focus { background: #00408b;}
.mc-main .mc_workshop .event-title, .mc-main .mc_workshop .event-title a { background: #d2f9c7; color: #000000; }
.mc-main .mc_workshop .event-title a:hover, .mc-main .mc_workshop .event-title a:focus { background: #fffffa;}
.mc-event-visible {
	display: block!important;
}
-->
</style><meta name="news_keywords" content="collision, Port Isabel, RAYMONDVILLE, Willacy County" />
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "Article",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/"
    },
    "headline": "Three Die in Collision in Raymondville; May Be Alcohol Related",
    "image": {
        "@type": "ImageObject",
        "url": "http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170708/three-die-in-collision-in-raymondville-may-be-alcohol-related.jpg",
        "width": "auto",
        "height": "auto"
    },
    "datePublished": "2017-05-12T22:02:01-0500",
    "dateModified": "2017-05-12T22:02:01-0500",
    "author": {
        "@type": "Person",
        "name": "The Valley's Fox News"
    },
    "publisher": {
        "@type": "Organization",
        "name": "KFXV The Valley&#039;s Fox News",
        "logo": {
            "@type": "ImageObject",
            "url": "http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/FOX_KFXV_STYLE_200.png",
            "width": "auto",
            "height": "auto"
        }
    },
    "description": "RAYMONDVILLE (KFXV) -- This afternoon, police responded to a collision that has left three dead. According to "
}
</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<style type="text/css" id="extra-dynamic-styles-sidebar_width-width">

		@media only screen and (min-width: 1025px) {
		.with_sidebar .et_pb_extra_column_sidebar {
			min-width: 29%;
			max-width: 29%;
			width: 29%;
			flex-basis: 29%;
		}
		.with_sidebar .et_pb_extra_column_main {
			min-width: 71%;
			max-width: 71%;
			width: 71%;
			flex-basis: 71%;
		}
		}
		</style>

<style type="text/css" id="extra-dynamic-styles-accent_color-color">
.widget_et_recent_tweets .widget_list a,
.widget_et_recent_tweets .et-extra-icon,
.widget_et_recent_tweets .widget-footer .et-extra-social-icon,
.widget_et_recent_tweets .widget-footer .et-extra-social-icon::before,
.project-details .project-details-title,
.et_filterable_portfolio .filterable_portfolio_filter a.current,
.et_extra_layout .et_pb_column .module-head h1,
.et_pb_extra_column .module-head h1,
#portfolio_filter a.current,
.woocommerce div.product div.summary .product_meta a,
.woocommerce-page div.product div.summary .product_meta a,
.et_pb_widget.woocommerce .product_list_widget li .amount,
.et_pb_widget li a:hover, .et_pb_widget.woocommerce .product_list_widget li a:hover,
.et_pb_widget.widget_et_recent_videos .widget_list .title:hover,
.et_pb_widget.widget_et_recent_videos .widget_list .title.active,
.woocommerce .woocommerce-info:before {
	color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-accent_color-background-color">
.single .score-bar,
.widget_et_recent_reviews .review-breakdowns .score-bar,
.et_pb_extra_module .posts-list article .post-thumbnail,
.et_extra_other_module .posts-list article .post-thumbnail,
.et_pb_widget .widget_list_portrait,
.et_pb_widget .widget_list_thumbnail,
.quote-format,
.link-format,
.audio-format .audio-wrapper,
.paginated .pagination li.active,
.score-bar,
.review-summary-score-box,
.post-footer .rating-stars #rating-stars img.star-on,
.post-footer .rating-stars #rated-stars img.star-on,
.author-box-module .author-box-avatar,
.timeline-menu li.active a:before,
.woocommerce div.product form.cart .button,
.woocommerce-page div.product form.cart .button,
.woocommerce div.product form.cart .read-more-button,
.woocommerce-page div.product form.cart .read-more-button,
.woocommerce div.product form.cart .post-nav .nav-links .button,
.woocommerce-page div.product form.cart .post-nav .nav-links .button,
.woocommerce .woocommerce-message, .woocommerce-page .woocommerce-message {
	background-color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-accent_color-border-color">
#et-menu > li > ul,
#et-menu li > ul,
#et-menu > li > ul > li > ul,
.et-top-search-primary-menu-item .et-top-search,
.et_pb_module,
.module,
.page article,
.authors-page .page,
#timeline-sticky-header,
.et_extra_other_module,
.woocommerce .woocommerce-info {
	border-color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_heading_font_size-font-size">
h1,
h2,
h3,
h4,
h5,
h6,
h1 a,
h2 a,
h3 a,
h4 a,
h5 a,
h6 a {
	font-size: 20px;
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_heading_line_height-line-height">
h1,
h2,
h3,
h4,
h5,
h6,
h1 a,
h2 a,
h3 a,
h4 a,
h5 a,
h6 a {
	line-height: 1.1em;
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_line_height-line-height">
body,
p {
	line-height: 1.4em;
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_heading_font_style-font-style">
h1,
h2,
h3,
h4,
h5,
h6,
h1 a,
h2 a,
h3 a,
h4 a,
h5 a,
h6 a {
	font-weight: bold; font-style: normal; text-transform: none; text-decoration: none; 
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_heading_font-font-family">
h1,
h2,
h3,
h4,
h5,
h6,
h1 a,
h2 a,
h3 a,
h4 a,
h5 a,
h6 a {
	font-family: 'Abel', Helvetica, Arial, Lucida, sans-serif;
}

</style>

<style type="text/css" id="extra-dynamic-styles-body_text_color-color">
body {
	color: rgba(0,0,0,0.82);
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_font_size-font-size">
#et-menu li a {
	font-size: 18px;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_font-font-family">
#et-menu li {
	font-family: 'Abel', Helvetica, Arial, Lucida, sans-serif;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_font_style-font-style">
#et-navigation ul li,
#et-navigation li a,
#et-navigation > ul > li > a {
	font-weight: normal; font-style: normal; text-transform: uppercase; text-decoration: none; 
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_text_color-color">
#et-menu > li a,
#et-menu > li.menu-item-has-children > a:after,
#et-menu > li.mega-menu-featured > a:after,
#et-extra-mobile-menu > li.mega-menu-featured > a:after {
	color: #ffffff;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-color">
#et-menu > li > a:hover,
#et-menu > li.menu-item-has-children > a:hover:after,
#et-menu > li.mega-menu-featured > a:hover:after,
#et-navigation > ul#et-menu > li.current-menu-item > a,
#et-navigation > ul#et-menu > li.current_page_item > a,
#et-extra-mobile-menu > li.mega-menu-featured > a:hover:after,
#et-extra-mobile-menu > li.current-menu-item > a,
#et-extra-mobile-menu > li.current_page_item > a,
#et-extra-mobile-menu > li > a:hover {
	color: #ff0000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-background-color">
#et-navigation > ul > li > a:before {
	background-color: #ff0000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_background_color-background-color">
#main-header {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_dropdown_background_color-background-color">
#et-menu > li > ul,
#et-menu li > ul,
#et-menu > li > ul > li > ul,
#et-mobile-navigation nav,
.et-top-search-primary-menu-item .et-top-search {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_dropdown_line_color-border-color">
#et-menu li.mega-menu-featured > ul li.menu-item .recent-list .recent-post,
#et-extra-mobile-menu li.mega-menu-featured > ul li.menu-item .recent-list .recent-post,
#et-menu li.mega-menu > ul > li > a,
#et-menu li.mega-menu > ul li:last-child a,
#et-menu li > ul li a {
	border-color: rgba(255,255,255,0.72);
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_font_style-font-style">
#et-secondary-menu li,
#et-secondary-menu li a {
	font-weight: normal; font-style: normal; text-transform: uppercase; text-decoration: none; 
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_background_color-background-color">
#top-header {
	background-color: #ffffff;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_text_color-color">
#et-secondary-menu a,
#et-secondary-menu li.menu-item-has-children > a:after {
	color: rgba(99,99,99,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_active_link_color-color">
#et-secondary-menu li a:hover,
#et-secondary-menu > li > a:hover:before,
#et-secondary-menu li.menu-item-has-children > a:hover:after,
#et-secondary-menu li.current-menu-item > a {
	color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_active_link_color-text-shadow">
#et-secondary-menu > li > a:hover:before {
	text-shadow: 10px 0 #dd3333, -10px 0 #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_dropdown_background_color-background-color">
#et-secondary-nav #et-secondary-menu {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_font_size-custom">
#et-trending-label,
		.et-trending-post a {
			font-size: 12.000000px;
		}
		#et-trending-button {
			width: 17.142857px;
			height: 17.142857px;
		}
		#et-trending-button span {
			width: 17.142857px;
			height: 1.714286px;
		}
		#et-trending-button.toggled span:first-child {
			-webkit-transform: translateY(5.571429px) rotate(45deg);
			transform: translateY(5.571429px) rotate(45deg);
		}
		#et-trending-button.toggled span:last-child {
			-webkit-transform: translateY(-5.571429px) rotate(-45deg);
			transform: translateY(-5.571429px) rotate(-45deg);
		}</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_font-font-family">
#et-trending-label,
.et-trending-post a {
	font-family: 'Droid Sans', Helvetica, Arial, Lucida, sans-serif;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_font_style-font-style">
#et-trending-label,
.et-trending-post a {
	font-weight: normal; font-style: italic; text-transform: none; text-decoration: none; 
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_label_text_color-color">
#et-trending-label,
#et-trending-button {
	color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_label_text_color-background-color">
#et-trending-button span {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_trending_title_text_color-color">
header.header .et-trending-post a,
header.header .et-trending-post a:visited {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_icon_search_cart_font-font-family">
#et-info .et-cart span,
#et-info .et-top-search .et-search-field {
	font-family: 'Droid Sans', Helvetica, Arial, Lucida, sans-serif;
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_icon_search_cart_background_color-background-color">
#et-info .et-cart,
#et-info .et-top-search .et-search-field,
#et-info .et-extra-social-icons .et-extra-icon {
	background-color: rgba(0,0,0,0.05);
}

</style>

<style type="text/css" id="extra-dynamic-styles-secondary_nav_icon_search_cart_text_color-color">
#et-info .et-cart,
#et-info .et-top-search .et-search-field,
#et-info .et-top-search .et-search-submit:before,
#et-info .et-extra-social-icons .et-extra-icon,
#et-info .et-extra-social-icons .et-extra-icon:before {
	color: rgba(0,0,0,0.23);
}

</style>

<style type="text/css" id="extra-dynamic-styles-fixed_primary_nav_active_link_color-color">
.et-fixed-header #et-navigation > ul#et-menu > li.current-menu-item > a,
.et-fixed-header #et-navigation > ul#et-menu > li.li.current_page_item > a,
.et-fixed-header #et-navigation > ul#et-menu > li > a:hover,
.et-fixed-header #et-navigation > ul#et-menu > li.menu-item-has-children > a:hover:after,
.et-fixed-header #et-navigation > ul#et-menu > li.mega-menu-featured > a:hover:after,
.et-fixed-header #et-extra-mobile-menu > li.mega-menu-featured > a:hover:after {
	color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-fixed_primary_nav_active_link_color-background-color">
.et-fixed-header #et-navigation > ul > li > a:before {
	background-color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-fixed_primary_nav_background_color-background-color">
.et-fixed-header #main-header {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-footer_heading_font_size-font-size">
#footer h4,
#footer .et_pb_widget h4.widgettitle {
	font-size: 20px;
}

</style>

<style type="text/css" id="extra-dynamic-styles-footer_widget_link_color-color">
#footer .et_pb_widget a,
#footer .et_pb_widget a:visited,
#footer .et_pb_widget a span,
#footer .et_pb_widget ul li a,
#footer .et_pb_widget .widget-list li a,
#footer .et_pb_widget #recentcomments li a,
#footer .widget .title {
	color: rgba(255,255,255,0.79);
}

</style>

<style type="text/css" id="extra-dynamic-styles-footer_widget_bullet_color-color">
.et_pb_widget ul li .children a:before,
.et_pb_widget .widget-list li .children a:before,
.widget.woocommerce .product_list_widget li .children a:before {
	color: rgba(221,51,51,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-footer_bottom_background_color-background-color">
#footer-bottom {
	background-color: #000000;
}

</style>

<style type="text/css" id="extra-dynamic-styles-footer_bottom_menu_active_link_color-color">
#footer-nav ul li a:hover,
#footer-nav ul li a:active {
	color: #dd3333;
}

</style>

<style type="text/css" id="extra-dynamic-styles-extra_nav_height_value">

			@media only screen and (min-width: 768px) {
				#main-header .logo {
					height: 104px;
					margin: 13px 0;
				}
				.header.left-right #et-navigation > ul > li > a {
					padding-bottom: 56px;
				}
			}
			@media only screen and (min-width: 768px) {
				.et-fixed-header #main-header .logo {
					height: 40.8px;
					margin: 19.6px 0;
				}
				.et-fixed-header .header.left-right #et-navigation > ul > li > a {
					padding-bottom: 32px;
				}
			}</style>
<link rel="shortcut icon" href="http://s3.amazonaws.com/foxrio2/wp-content/uploads/2017/03/appicon.jpg" /><link rel='canonical' href='http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/' />
<link rel="amphtml" href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/amp/" /><meta name="google-site-verification" content="GVYPsB3kF2X90_RJb7OfD41IUeuJsPVJ65Ztgx9J8IY" />
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/site_cfg.js"></script>
<script type="text/javascript">
    var p="https",d="s";
    var z=document.createElement("script");
    z.type="text/javascript"; z.async=true; z.src=p+"://"+d+".zkcdn.net/ados.js";
    var s=document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(z,s);
</script>
<script type="text/javascript">
    var ados = ados || {};
    var _pm_keywords = _pm_keywords || "";
    var prpt = prpt || {};
    var _pm_vi_157573 = _pm_vi_157573 || 0;
    ados.run = ados.run || [];
    ados.run.push(function() {
    ados_setDomain("engine.tentaculos.net");
    ados_setKeywords(_pm_keywords);
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [320x50][ADHESION] - 320x50-->
    prpt["vi"] = _pm_vi_157573;
    ados_add_placement(9746, 330182, "adz96145", 23).setZone(157573).setProperties(prpt);
    ados_load();
    });
</script>
<script type="text/javascript">
    var p="http",d="static";
    if(document.location.protocol=="https:"){ p+="s";d="engine"; }
    var z=document.createElement("script");
    z.type="text/javascript"; z.async=true; z.src=p+"://"+d+".tentaculos.net/ados.js";
    var s=document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(z,s);
</script>
<script type="text/javascript">
  var ados = ados || {};
  var _pm_keywords = _pm_keywords || "";
  var _pm_vi_139725 = _pm_vi_139725 || "";
  var _pm_vi_139726 = _pm_vi_139726 || "";
  var _pm_vi_139727 = _pm_vi_139727 || "";
  var _pm_vi_139728 = _pm_vi_139728 || "";
  var _pm_vi_139729 = _pm_vi_139729 || "";
  var _pm_vi_139730 = _pm_vi_139730 || "";
  var _pm_vi_139723 = _pm_vi_139723 || "";
  var _pm_vi_139724 = _pm_vi_139724 || "";
  var _pm_vi_139731 = _pm_vi_139731 || "";
  var _pm_vi_139732 = _pm_vi_139732 || "";
  var _pm_vi_139733 = _pm_vi_139733 || "";
  var _pm_vi_145789 = _pm_vi_145789 || "";
  var _pm_vi_145790 = _pm_vi_145790 || "";
    ados.run = ados.run || [];
    ados.run.push(function() {
    ados_setKeywords(_pm_keywords);
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [300x250][ATF] - 300x250-->
    ados_add_placement(9791, 330182, "adz51584", 5).setZone(139725).setProperties({"vi": _pm_vi_139725});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [300x250][BTF][1] - 300x250-->
    ados_add_placement(9791, 330182, "adz77016", 5).setZone(139726).setProperties({"vi": _pm_vi_139726});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [300x250][BTF][2] - 300x250-->
    ados_add_placement(9791, 330182, "adz86508", 5).setZone(139727).setProperties({"vi": _pm_vi_139727});
  <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [300x600][BTF] - 300x600-->
    ados_add_placement(9791, 330182, "adz67999", 43).setZone(139728).setProperties({"vi": _pm_vi_139728});
  <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [320x50][ATF] - 320x50-->
    ados_add_placement(9791, 330182, "adz95577", 23).setZone(139729).setProperties({"vi": _pm_vi_139729});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [320x50][BTF] - 320x50-->
    ados_add_placement(9791, 330182, "adz62753", 23).setZone(139730).setProperties({"vi": _pm_vi_139730});
  <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [728x90][ATF] - 728x90-->
    ados_add_placement(9791, 330182, "adz33786", 4).setZone(139723).setProperties({"vi": _pm_vi_139723});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [728x90][BTF] - 728x90-->
    ados_add_placement(9791, 330182, "adz60969", 4).setZone(139724).setProperties({"vi": _pm_vi_139724});
  <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [Background][1x1] - 1x1-->
    ados_add_placement(9791, 330182, "adz34607", 163).setZone(139731).setProperties({"vi": _pm_vi_139731});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [Pencil Banner][1x1] - 1x1-->
    ados_add_placement(9791, 330182, "adz17606", 163).setZone(139732).setProperties({"vi": _pm_vi_139732});
    <!--ZONE: EV. foxrio2.com [McAllen][TV][EN] - [Splash Page][1x1] - 1x1-->
    ados_add_placement(9791, 330182, "adz70449", 163).setZone(139733).setProperties({"vi": _pm_vi_139733});
    ados_load();
    });
</script><link rel="icon" href="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/appicon-120x120.jpg" sizes="32x32" />
<link rel="icon" href="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/appicon.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/appicon.jpg" />
<meta name="msapplication-TileImage" content="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/appicon.jpg" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://foxrio2.com/?custom-css=8b72fc38d9" />
		
</head>
<body class="post-template-default single single-post postid-51838 single-format-standard et_extra et_fullwidth_nav et_fixed_nav et_pb_gutters1 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar chrome">
	<div id="page-container">
				<!-- Header -->
		<header class="header centered">
			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="80">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="http://foxrio2.com/" data-fixed-height="51">
							<img src="http://s3.amazonaws.com/foxrio2/wp-content/uploads/2017/03/FOX_KFXV_STYLE_200.png" alt="KFXV The Valley&#039;s Fox News" id="logo" />
						</a>

						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-34811" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-34811"><a href="http://foxrio2.com/category/news/">News</a><ul class="sub-menu" style="border-top-color: #5496d3;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="http://foxrio2.com/gps-leads-to-arrest-in-homicide-investigation/" title="GPS Leads to Arrest in Homicide Investigation" class="featured-image">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170905/gps-leads-to-arrest-in-homicide-investigation-440x264.jpg" alt="GPS Leads to Arrest in Homicide Investigation" />
			</a>
							<h2>GPS Leads to Arrest in Homicide Investigation</h2>
							<div class="post-meta">
								<span class="updated">May 12, 2017</span> | <a href="http://foxrio2.com/category/news/" rel="tag">Local News</a> | <span class="rating-stars" title="Rating: 4.50"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-half rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="http://foxrio2.com/bp-sees-increase-in-smugglers-crossing-harder-drugs/" title="Border Patrol Sees Increase in Smugglers Crossing Harder Drugs" class="featured-image">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170824/bp-sees-increase-in-smugglers-crossing-harder-drugs-440x264.jpg" alt="Border Patrol Sees Increase in Smugglers Crossing Harder Drugs" />
			</a>
							<h2>Border Patrol Sees Increase in Smugglers Crossing Harder Drugs</h2>
							<div class="post-meta">
								<span class="updated">May 12, 2017</span> | <a href="http://foxrio2.com/category/news/" rel="tag">Local News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/investigation-into-death-of-minor/" title="Investigation Into Death of Minor">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170735/investigation-into-death-of-minor-150x150.jpg" alt="Investigation Into Death of Minor" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/investigation-into-death-of-minor/">Investigation Into Death of Minor</a></h3>
								by <a href="http://foxrio2.com/author/mleal/" class="url fn" title="Posts by The Valley&#039;s Fox News" rel="author">The Valley&#039;s Fox News</a> | <span class="updated">May 12, 2017</span> | <a class="comments-link" href="http://foxrio2.com/investigation-into-death-of-minor/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/" title="Harlingen Woman Killed in Hit and Run">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170721/harlingen-woman-killed-in-hit-and-run-150x150.jpg" alt="Harlingen Woman Killed in Hit and Run" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/">Harlingen Woman Killed in Hit and Run</a></h3>
								by <a href="http://foxrio2.com/author/mleal/" class="url fn" title="Posts by The Valley&#039;s Fox News" rel="author">The Valley&#039;s Fox News</a> | <span class="updated">May 12, 2017</span> | <a class="comments-link" href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" title="Three Die in Collision in Raymondville; May Be Alcohol Related">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170708/three-die-in-collision-in-raymondville-may-be-alcohol-related-150x150.jpg" alt="Three Die in Collision in Raymondville; May Be Alcohol Related" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">Three Die in Collision in Raymondville; May Be Alcohol Related</a></h3>
								by <a href="http://foxrio2.com/author/mleal/" class="url fn" title="Posts by The Valley&#039;s Fox News" rel="author">The Valley&#039;s Fox News</a> | <span class="updated">May 12, 2017</span> | <a class="comments-link" href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-36323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36323"><a href="http://foxrio2.com/category/special-reports/">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110"><a href="http://foxrio2.com/category/business/">Business News</a></li>
	<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="http://foxrio2.com/category/technology/">Technology News</a></li>
	<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="http://foxrio2.com/category/entertainment/">Entertainment News</a></li>
	<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="http://foxrio2.com/category/health/">Health News</a></li>
	<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="http://foxrio2.com/category/science/">Science News</a></li>
	<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="http://foxrio2.com/category/home-improvement/">Home Improvement</a></li>
	<li id="menu-item-34363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34363"><a href="http://foxrio2.com/category/strange/">Strange/Odd</a></li>
</ul>
</li>
<li id="menu-item-40883" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40883"><a href="http://www.foxrio2.com/weather/">Weather</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-11"><a href="http://foxrio2.com/category/sports/">Sports</a><ul class="sub-menu" style="border-top-color: #dd3333;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="http://foxrio2.com/tom-brady-the-latest-star-on-madden-game-cover/" title="Tom Brady the latest star on Madden game cover" class="featured-image">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12051203/TomBrady-440x264.jpg" alt="Tom Brady the latest star on Madden game cover" />
			</a>
							<h2>Tom Brady the latest star on Madden game cover</h2>
							<div class="post-meta">
								<span class="updated">May 12, 2017</span> | <a href="http://foxrio2.com/category/sports/" rel="tag">Sports</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="http://foxrio2.com/celtics-beat-bulls-108-97-take-3-2-lead-in-series/" title="Celtics beat Bulls 108-97, take 3-2 lead in series" class="featured-image">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/04/27050939/hosted2.ap_-440x264.jpg" alt="Celtics beat Bulls 108-97, take 3-2 lead in series" />
			</a>
							<h2>Celtics beat Bulls 108-97, take 3-2 lead in series</h2>
							<div class="post-meta">
								<span class="updated">Apr 27, 2017</span> | <a href="http://foxrio2.com/category/sports/" rel="tag">Sports</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/dale-earnhardt-jr-to-retire-from-nascar-at-end-of-season/" title="Dale Earnhardt Jr. to retire from NASCAR at end of season">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/04/25085844/865989b41605309b59092aeb50f86ec1-150x150.jpg" alt="Dale Earnhardt Jr. to retire from NASCAR at end of season" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/dale-earnhardt-jr-to-retire-from-nascar-at-end-of-season/">Dale Earnhardt Jr. to retire from NASCAR at end of season</a></h3>
								by <a href="http://foxrio2.com/author/associated-press/" class="url fn" title="Posts by Associated Press" rel="author">Associated Press</a> | <span class="updated">Apr 25, 2017</span> | <a class="comments-link" href="http://foxrio2.com/dale-earnhardt-jr-to-retire-from-nascar-at-end-of-season/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/researchers-to-look-for-cte-evidence-in-hernandezs-brain/" title="Researchers to look for CTE evidence in Hernandez&#8217;s brain">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/04/21045430/2-format2403-150x150.jpg" alt="Researchers to look for CTE evidence in Hernandez&#8217;s brain" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/researchers-to-look-for-cte-evidence-in-hernandezs-brain/">Researchers to look for CTE evidence in Hernandez&#039;s brain</a></h3>
								by <a href="http://foxrio2.com/author/associated-press/" class="url fn" title="Posts by Associated Press" rel="author">Associated Press</a> | <span class="updated">Apr 21, 2017</span> | <a class="comments-link" href="http://foxrio2.com/researchers-to-look-for-cte-evidence-in-hernandezs-brain/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="http://foxrio2.com/a-long-tearful-road-to-a-major-for-sergio-garcia/" title="A long, tearful road to a major for Sergio Garcia">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/04/10045513/ad7c292a-aa48-4670-88cd-3f792c31c0a6-150x150.jpg" alt="A long, tearful road to a major for Sergio Garcia" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="http://foxrio2.com/a-long-tearful-road-to-a-major-for-sergio-garcia/">A long, tearful road to a major for Sergio Garcia</a></h3>
								by <a href="http://foxrio2.com/author/associated-press/" class="url fn" title="Posts by Associated Press" rel="author">Associated Press</a> | <span class="updated">Apr 10, 2017</span> | <a class="comments-link" href="http://foxrio2.com/a-long-tearful-road-to-a-major-for-sergio-garcia/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-540"><a href="http://foxrio2.com/event-calendar/">Events</a></li>
<li id="menu-item-36817" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36817"><a title="Whats Fox 2 on right now!" href="http://www.foxrio2.com/programming/">Programming</a></li>
<li id="menu-item-4590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4590"><a href="http://foxrio2.com/about-us/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-4606" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4606"><a href="http://foxrio2.com/about-us/anchors-reporters/">Anchors and Reporters</a></li>
	<li id="menu-item-40871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40871"><a href="http://foxrio2.com/about-us/news-tips/">News Tips?</a></li>
	<li id="menu-item-40872" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40872"><a href="http://foxrio2.com/about-us/news-tips/employment/">Employment</a></li>
	<li id="menu-item-40867" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40867"><a href="http://foxrio2.com/about-us/programming-questions/">Programming Questions?</a></li>
	<li id="menu-item-40870" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40870"><a href="http://foxrio2.com/about-us/site-issues/">Site Issues?</a></li>
	<li id="menu-item-40869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40869"><a href="http://foxrio2.com/about-us/rssfeeds/">RSS Feeds</a></li>
	<li id="menu-item-40864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40864"><a href="http://foxrio2.com/about-us/advertise/">Advertise</a></li>
	<li id="menu-item-40868" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40868"><a href="http://foxrio2.com/about-us/public-fcc-file/">Public FCC File</a></li>
	<li id="menu-item-40865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40865"><a href="http://foxrio2.com/about-us/closed-captioning/">Closed Captioning</a></li>
	<li id="menu-item-40866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40866"><a href="http://foxrio2.com/about-us/eeo-report/">EEO Report</a></li>
</ul>
</li>
<li id="menu-item-51290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51290"><a title="Submit a News Tip" href="http://foxrio2.com/about-us/news-tips/">News Tips?</a>
<ul class="sub-menu">
	<li id="menu-item-51481" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51481"><a href="http://foxrio2.com/users-photo-gallery/">Viewer Submitted Photos</a></li>
</ul>
</li>
<li class="menu-item et-top-search-primary-menu-item" style=""><span id="et-search-icon" class="search-icon"></span><div class="et-top-search"><form role="search" class="et-search-form" method="get" action="http://foxrio2.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form></div></li></ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->

					</div><!-- /.container -->
				</div><!-- /#main-header -->
<!--
-->




			</div><!-- /#main-header-wrapper -->
		</header>


		

		<div id="main-content">
	<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-51838" class="module single-post-module post-51838 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-collision tag-port-isabel tag-raymondville tag-willacy-county et-has-post-format-content et_post_format-et-post-format-standard">

<div id="breadcrumbs" typeof="BreadcrumbList" vocab="http://schema.org/">
    <!-- Breadcrumb NavXT 5.7.0 -->
<span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to KFXV The Valley&#039;s Fox News." href="http://foxrio2.com" class="home"><span property="name">KFXV The Valley&#039;s Fox News</span></a><meta property="position" content="1"></span> &gt; <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to the Local News category archives." href="http://foxrio2.com/category/news/" class="taxonomy category"><span property="name">Local News</span></a><meta property="position" content="2"></span> &gt; <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" title="Go to Three Die in Collision in Raymondville; May Be Alcohol Related." href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" class="post post-post current-item"><span property="name">Three Die in Collision in Raymondville; May Be Alcohol Related</span></a><meta property="position" content="3"></span></div>

<center><!-- EV. foxrio2.com [McAllen][TV][Display][728x90][ATF][0]-->
<div id="adz33786"></div> <script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/139723_a.js"></script>
</center>
 
														<div class="post-header">
								<h1 class="entry-title">Three Die in Collision in Raymondville; May Be Alcohol Related</h1>
								<div class="post-meta">
									<p>Posted by <a href="http://foxrio2.com/author/mleal/" class="url fn" title="Posts by The Valley&#039;s Fox News" rel="author">The Valley&#039;s Fox News</a> | <span class="updated">May 12, 2017</span> | <a href="http://foxrio2.com/category/news/" rel="tag">Local News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<a href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" title="Three Die in Collision in Raymondville; May Be Alcohol Related" class="featured-image">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170708/three-die-in-collision-in-raymondville-may-be-alcohol-related-1280x640.jpg" alt="Three Die in Collision in Raymondville; May Be Alcohol Related" />
			</a>							</div>
							
																					<div class="et_pb_extra_row etad post_above">
								<div class="adsense-responsive-ad"><center style="padding-top:5px;padding-bottom:5px;margin:0 auto;max-width:100%;"><div id="adz33786"></div>
<script data-cfasync="false"  src="https://c2.tentaculos.net/zonedata/330182/139723_a.js"></script></center></div>							</div>
							
							<div class="post-wrap">
															<div class="post-content entry-content">
									

<!-- BEGIN ARTICLE AGE CHECKER -->				
		
<!-- END ARTICLE AGE CHECKER -->		

<!-- BEGIN OOYALA VIDEO -->


				<style>.oo-player-container .oo-player{z-index: 1!important;}</style>
								
				<script src="//player.ooyala.com/static/v4/stable/latest/core.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/video-plugin/main_html5.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/skin-plugin/html5-skin.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/video-plugin/bit_wrapper.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/video-plugin/osmf_flash.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/other-plugin/discovery_api.min.js"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/ad-plugin/google_ima.min.js" language="javascript"></script>
				<script src="//player.ooyala.com/static/v4/stable/latest/analytics-plugin/googleAnalytics.min.js"></script>

				<link rel="stylesheet" href="//player.ooyala.com/static/v4/stable/latest/skin-plugin/html5-skin.min.css"/>
				
				<div id="ooyala_video_player_container-q1dwg2yje6alr4pyideunvc0xc8svpuq" style="width:100%"></div>

				<script type="text/javascript">
		
					var oo_player;	
					
					var playerParam = {
						'pcode': 'NvN2cxOgzcdj8JNBB_temgE4lk2J',
						'playerBrandingId': 'df0e3c0f44eb4d538384149aa03349a5',
						'autoplay': false,
						'loop': false,
						'skin': {
							'config': '//player.ooyala.com/static/v4/stable/latest/skin-plugin/skin.json'
						},
						'onCreate': function(player) {	
							
						}
					};
					
					OO.ready(function() {
						oo_player = OO.Player.create('ooyala_video_player_container-q1dwg2yje6alr4pyideunvc0xc8svpuq', 'Q1dWg2YjE6Alr4PyidEUnVC0xc8SvpUQ', playerParam); 
					});
					
				</script><p>RAYMONDVILLE (KFXV) &#8212; This afternoon, police responded to a collision that has left three dead. </p>
<p>According to authorities, the incident happened on Highway 77, south of Conley Road in <a class="StrictlyAutoTagAnchor" href="http://foxrio2.com/tag/willacy-county/" title="Find more articles about Willacy County ">Willacy County</a>.<br />
The driver of an Cadillac Escalade impacted another truck.<br />
Police identified the driver of the Escalade as 23-year-old, Abraham Cerda, originally from Brownsville. The two passengers in the other vehicle were identified as 72-year-old, Iban Rafael Garza, and 69-year-old, Catalina Garza &#8212; both from <a class="StrictlyAutoTagAnchor" href="http://foxrio2.com/tag/port-isabel/" title="Find more articles about Port Isabel ">Port Isabel</a>. All three died due to their injuries sustained in the impact. </p>
<p>An investigation continues as to the cause of the accident, but believe alcohol played a factor.  </p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>ALSO ON RGVFOX</em></h3>
</div><!-- END OOYALA VIDEO -->

									


								</div>
							<!-- The Tags  -->		
<div class="the_tags">
<center>		
<ul class=taglist><li class=tag><a href="http://foxrio2.com/tag/collision/" rel="tag">collision</a></li><li class=tag><a href="http://foxrio2.com/tag/port-isabel/" rel="tag">Port Isabel</a></li><li class=tag><a href="http://foxrio2.com/tag/raymondville/" rel="tag">RAYMONDVILLE</a></li><li class=tag><a href="http://foxrio2.com/tag/willacy-county/" rel="tag">Willacy County</a></li></ul></center>
</div>
							</div>

														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;t=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Facebook" data-network-name="facebook" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/home?status=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related%20http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Twitter" data-network-name="twitter" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;t=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Google +" data-network-name="googleplus" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;t=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Tumblr" data-network-name="tumblr" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;description=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related&#038;media=http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170708/three-die-in-collision-in-raymondville-may-be-alcohol-related-450x255.jpg" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Pinterest" data-network-name="pinterest" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;title=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/&#038;title=Three%20Die%20in%20Collision%20in%20Raymondville%3B%20May%20Be%20Alcohol%20Related" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Email" data-network-name="basic_email" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Three Die in Collision in Raymondville; May Be Alcohol Related&quot; via Print" data-network-name="basic_print" data-share-title="Three Die in Collision in Raymondville; May Be Alcohol Related" data-share-url="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="51838" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #5496d3;
									}
								</style>
							</div>

																					<div class="et_pb_extra_row etad post_below">
								<div class="adsense-responsive-ad"><center style="margin: 0 auto;max-width:100%;"><div id="adz60969"></div>
<script data-cfasync="false"  src="https://c2.tentaculos.net/zonedata/330182/139724_a.js"></script>
</center>

</div>							</div>
													</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="http://foxrio2.com/mexico-ranks-second-deadliest-country-in-world-experts-weigh-in/" rel="prev"><span class="button">Previous</span><span class="title">Mexico Ranks Second Deadliest Country in World; Experts Weigh In</span></a>								</div>
								<div class="nav-link nav-link-next">
									<a href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/" rel="next"><span class="button">Next</span><span class="title">Harlingen Woman Killed in Hit and Run</span></a>								</div>
							</div>
						</nav>
												<div class="et_extra_other_module author-box vcard">
							<div class="author-box-header">
								<h3>About The Author</h3>
							</div>
							<div class="author-box-content clearfix">
								<div class="author-box-avatar">
									<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/03/FOX_KFXV_STYLE_200.png" width="170" height="111" alt="The Valley's Fox News" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" />								</div>
								<div class="author-box-description">
									<h4><a class="author-link url fn" href="http://foxrio2.com/author/mleal/" rel="author" title="View all posts by The Valley's Fox News">The Valley's Fox News</a></h4>
									<p class="note">KFXV-LD channel 67 is a Fox-affiliated station in McAllen, Texas, owned by Entravision Communications. KFXV can be seen on Time Warner Cable channel 6 and digital high definition channel 870.</p>
									<ul class="social-icons">
																					<li><a href="https://www.facebook.com/rgvfox" target="_blank"><span class="et-extra-icon et-extra-icon-facebook et-extra-icon-color-hover"></span></a></li>
																					<li><a href="http://twitter.com/rgvfox" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li>
																					<li><a href="https://plus.google.com/+foxrio2" target="_blank"><span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-color-hover"></span></a></li>
																					<li><a href="https://www.pinterest.com/foxrio2/" target="_blank"><span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-color-hover"></span></a></li>
																					<li><a href="http://foxrio2.tumblr.com/" target="_blank"><span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-color-hover"></span></a></li>
																					<li><a href="https://www.instagram.com/rgvfox/" target="_blank"><span class="et-extra-icon et-extra-icon-instagram et-extra-icon-color-hover"></span></a></li>
																			</ul>
								</div>
							</div>
						</div>
						
												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="http://foxrio2.com/man-arrested-for-animal-abuse-after-video-goes-viral/" title="Animal Abuse Video Goes Viral; Leads to Arrest" class="post-thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/02/man-arrested-for-animal-abuse-after-video-goes-viral-440x264.jpg" alt="Animal Abuse Video Goes Viral; Leads to Arrest" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="http://foxrio2.com/man-arrested-for-animal-abuse-after-video-goes-viral/">Animal Abuse Video Goes Viral; Leads to Arrest</a></h4>
									<p class="date"><span class="updated">February 16, 2017</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="http://foxrio2.com/5-dead-27-injured-in-reynosa-accident/" title="5 Dead, 27 Injured in Reynosa Accident" class="post-thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2016/08/5-dead-27-injured-in-reynosa-accident-440x264.jpg" alt="5 Dead, 27 Injured in Reynosa Accident" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="http://foxrio2.com/5-dead-27-injured-in-reynosa-accident/">5 Dead, 27 Injured in Reynosa Accident</a></h4>
									<p class="date"><span class="updated">August 30, 2016</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="http://foxrio2.com/free-healthcare-for-rgv-residents-at-free-mega-clinic/" title="Free Healthcare for RGV Residents at Free Mega Clinic" class="post-thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2016/06/free-healthcare-for-rgv-residents-at-free-mega-clinic-440x264.jpg" alt="Free Healthcare for RGV Residents at Free Mega Clinic" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="http://foxrio2.com/free-healthcare-for-rgv-residents-at-free-mega-clinic/">Free Healthcare for RGV Residents at Free Mega Clinic</a></h4>
									<p class="date"><span class="updated">June 24, 2016</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="http://foxrio2.com/cyclist-struck-down-by-vehicle-identified/" title="Cyclist struck down by vehicle Identified" class="post-thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2014/09/20140129a8cyclist_thumb17.jpg" alt="Cyclist struck down by vehicle Identified" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="http://foxrio2.com/cyclist-struck-down-by-vehicle-identified/">Cyclist struck down by vehicle Identified</a></h4>
									<p class="date"><span class="updated">January 29, 2014</span></p>
								</div>
																							</div>
						</div>
										
				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
				
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/three-die-in-collision-in-raymondville-may-be-alcohol-related/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=27402049&#038;postid=51838&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=wp_user_avatar&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.9&#038;sig=2e2285f75172523bfcee0c428caeb61e28d26068#parent=http%3A%2F%2Ffoxrio2.com%2Fthree-die-in-collision-in-raymondville-may-be-alcohol-related%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

			</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="text-12" class="et_pb_widget widget_text"><h4 class="widgettitle">ADVERTISEMENT</h4>			<div class="textwidget"><!--[300X100]--> 
<center style="margin: 0 auto;">
<div id="adz95577"></div>
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/139729_a.js"></script>
</center></div>
		</div> <!-- end .et_pb_widget --><div id="text-18" class="et_pb_widget widget_text"><h4 class="widgettitle">Weather</h4>			<div class="textwidget"><p><a href="//foxrio2.com/weather/"><iframe id="forecast_embed" type="text/html" frameborder="0" height="245" width="100%" src="https://forecast.io/embed/#lat=26.2164&lon=-98.2364&name=McAllen"> </iframe></a></p>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ADVERTISEMENT</h4>			<div class="textwidget"><!--[300x250] -->
<div id="adz51584"></div>
<script data-cfasync="false"  src="//c2.tentaculos.net/zonedata/330182/139725_a.js"></script>
</div>
		</div> <!-- end .et_pb_widget -->		<div id="et-recent-posts-2" class="et_pb_widget widget_et_recent_entries">		<h4 class="widgettitle">Recently Added</h4>		<ul class="widget_list">
					<li>
									<a href="http://foxrio2.com/gps-leads-to-arrest-in-homicide-investigation/" title="GPS Leads to Arrest in Homicide Investigation" class="widget_list_thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170905/gps-leads-to-arrest-in-homicide-investigation-150x150.jpg" alt="GPS Leads to Arrest in Homicide Investigation" />
			</a>								<div class="post_info">
					<a href="http://foxrio2.com/gps-leads-to-arrest-in-homicide-investigation/" class="title">GPS Leads to Arrest in Homicide Investigation</a>
										<div class="post-meta">
						<a href="http://foxrio2.com/category/news/" rel="tag">Local News</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://foxrio2.com/bp-sees-increase-in-smugglers-crossing-harder-drugs/" title="Border Patrol Sees Increase in Smugglers Crossing Harder Drugs" class="widget_list_thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170824/bp-sees-increase-in-smugglers-crossing-harder-drugs-150x150.jpg" alt="Border Patrol Sees Increase in Smugglers Crossing Harder Drugs" />
			</a>								<div class="post_info">
					<a href="http://foxrio2.com/bp-sees-increase-in-smugglers-crossing-harder-drugs/" class="title">Border Patrol Sees Increase in Smugglers Crossing Harder Drugs</a>
										<div class="post-meta">
						<a href="http://foxrio2.com/category/news/" rel="tag">Local News</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://foxrio2.com/investigation-into-death-of-minor/" title="Investigation Into Death of Minor" class="widget_list_thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170735/investigation-into-death-of-minor-150x150.jpg" alt="Investigation Into Death of Minor" />
			</a>								<div class="post_info">
					<a href="http://foxrio2.com/investigation-into-death-of-minor/" class="title">Investigation Into Death of Minor</a>
										<div class="post-meta">
						<a href="http://foxrio2.com/category/news/" rel="tag">Local News</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/" title="Harlingen Woman Killed in Hit and Run" class="widget_list_thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170721/harlingen-woman-killed-in-hit-and-run-150x150.jpg" alt="Harlingen Woman Killed in Hit and Run" />
			</a>								<div class="post_info">
					<a href="http://foxrio2.com/harlingen-woman-killed-in-hit-and-run/" class="title">Harlingen Woman Killed in Hit and Run</a>
										<div class="post-meta">
						<a href="http://foxrio2.com/category/news/" rel="tag">Local News</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" title="Three Die in Collision in Raymondville; May Be Alcohol Related" class="widget_list_thumbnail">
				<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/12170708/three-die-in-collision-in-raymondville-may-be-alcohol-related-150x150.jpg" alt="Three Die in Collision in Raymondville; May Be Alcohol Related" />
			</a>								<div class="post_info">
					<a href="http://foxrio2.com/three-die-in-collision-in-raymondville-may-be-alcohol-related/" class="title">Three Die in Collision in Raymondville; May Be Alcohol Related</a>
										<div class="post-meta">
						<a href="http://foxrio2.com/category/news/" rel="tag">Local News</a>					</div>
				</div>
			</li>
						</ul>
		</div> <!-- end .et_pb_widget --><div id="text-15" class="et_pb_widget widget_text"><h4 class="widgettitle">ADVERTISEMENT</h4>			<div class="textwidget"><!-- [300x600] -->
<center style="margin: 0 auto;">
<div id="adz67999"></div>
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/139728_a.js"></script>
</center></div>
		</div> <!-- end .et_pb_widget --><div id="text-10" class="et_pb_widget widget_text"><h4 class="widgettitle">Border Crossing Times</h4>			<div class="textwidget"><center style="margin: 0 auto;"><a href="//www.foxrio2.com/weather/border-crossing-times/"><img src="https://s3.amazonaws.com/foxrio2/wp-content/uploads/2013/10/BRIDGEWAITTIMES.jpg" width="100%" height="auto" alt="Bridge Wait Times"></a></center></div>
		</div> <!-- end .et_pb_widget --><div id="text-5" class="et_pb_widget widget_text"><h4 class="widgettitle">ADVERTISEMENT</h4>			<div class="textwidget"><center style="margin: 0 auto;">
<!-- [300x250] -->
<div id="adz96145"></div>
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/157573_a.js"></script>
</center>
</div>
		</div> <!-- end .et_pb_widget --><div id="fpw_widget-29" class="et_pb_widget widget_fpw_widget"><h4 class="widgettitle">Contest</h4>
<article class="fpw-clearfix fpw-layout-big">

	<a href="http://foxrio2.com/mothers-day-contest/" class="fpw-featured-link">
		<div class="fpw-featured-image">
			<img width="300" height="600" src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/03103545/MothersDay_300x600.jpg" class="attachment-fpw_big size-fpw_big wp-post-image" alt="" srcset="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/03103545/MothersDay_300x600.jpg 300w, http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/05/03103545/MothersDay_300x600-225x450.jpg 225w" sizes="(max-width: 300px) 100vw, 300px" />		</div>
		<h3 class="fpw-page-title"></h3>
	</a>	

	<div class="fpw-excerpt">
			</div>

</article></div> <!-- end .et_pb_widget --><div id="et_ads-2" class="et_pb_widget widget_et_ads">		<div class="widget_content clearfix">
							<div class="etad">
									<a href="http://foxrio2.com/win-tickets-zz-top/" target="_blank">
						<img src="http://dcl9dohvvr1qz.cloudfront.net/wp-content/uploads/2017/04/27052346/ZZTOPSQUARE.png" alt="Contest" />
					</a>
							</div>
				</div>
		</div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
</div> <!-- #main-content -->
<style>		
#crimestoppersbox {display:block;padding:10px;width:80%;min-height:100px;background-color:#448aff;color: #fff;margin: 10px auto;border-radius: 15px;}		
.ooyala-player-container{		
    width: 100%;		
    height: 338px;		
}		
.st-post-tags a{		
    display:inline-block;		
    padding: 0 5px;		
    background: #000;		
    color: #fff !important;		
    margin: 0 4px;		
}	
.the_tags {width: fit-content;margin:0 auto;}
.tag {float:left;padding: 0 5px; background: #000; margin: 0 4px;color: #fff !important;display: inline-block;}		
.tag a {color: #fff !important;}		
.taglist {list-style-type: none;padding:0;}		
h1 {font-size: 190%;}		
</style>
	
	<footer id="footer" class="footer_columns_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle">Search Fox</h4><form role="search" method="get" class="search-form" action="http://foxrio2.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div> <!-- end .et_pb_widget --><div id="categories-2" class="et_pb_widget widget_categories"><h4 class="widgettitle">News</h4>		<ul>
	<li class="cat-item cat-item-11"><a href="http://foxrio2.com/category/business/" >Business</a>
</li>
	<li class="cat-item cat-item-8586"><a href="http://foxrio2.com/category/entertainment/" >Entertainment</a>
</li>
	<li class="cat-item cat-item-110"><a href="http://foxrio2.com/category/gooddayvalley/" title="Entertaining news following celebrity and pop culture stories every weekday morning!">Good Day Valley</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://foxrio2.com/category/health/" >Health</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://foxrio2.com/category/home-improvement/" title="Expert advice and informative articles on home improvement, remodeling, gardening and decorating.">Home Improvement</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://foxrio2.com/category/news/" >Local News</a>
</li>
	<li class="cat-item cat-item-6"><a href="http://foxrio2.com/category/science/" >Science</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://foxrio2.com/category/special-reports/" title="Special Reports Archive.">Special Reports</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://foxrio2.com/category/sports/" title="Your latest sports news">Sports</a>
</li>
	<li class="cat-item cat-item-6096"><a href="http://foxrio2.com/category/strange/" title="Oddities worth mentioning">Strange</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://foxrio2.com/category/technology/" title="Technology News you need">Technology</a>
</li>
		</ul>
</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-2">
					<div id="nav_menu-2" class="et_pb_widget widget_nav_menu"><h4 class="widgettitle">Television</h4><div class="menu-television-container"><ul id="menu-television" class="menu"><li id="menu-item-51667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51667"><a href="http://foxrio2.com/programming/">Programming</a></li>
<li id="menu-item-51665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51665"><a href="http://foxrio2.com/about-us/">About Us</a></li>
<li id="menu-item-51666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51666"><a href="http://foxrio2.com/about-us/advertise/">Advertise</a></li>
<li id="menu-item-51668" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51668"><a href="http://foxrio2.com/about-us/news-tips/employment/">Employment</a></li>
</ul></div></div> <!-- end .et_pb_widget --><div id="my_calendar_upcoming_widget-4" class="et_pb_widget widget_my_calendar_upcoming_widget"><h4 class="widgettitle"><a href='http://foxrio2.com/event-calendar/'>Events Calendar</a></h4><ul id='upcoming-events-cd29489654112fe396c442438c555974' class='upcoming-events'><!-- Cached -->
<li class="past-event mc_general"><strong><span class='mc_tb'>6:00 pm</span> <span>&ndash;</span> <span class='mc_te'>8:00 pm</span>, May 11, 2017</strong> – <a href='https://www.facebook.com/pg/STAMPRGV/events/'>S.T.A.M.P Meet &amp; Greet Mixer</a></li>

<li class="today mc_general"><strong><span class='mc_tb'>10:00 am</span> <span>&ndash;</span> <span class='mc_te'>4:00 pm</span>, May 13, 2017</strong> – <a href='https://mcallen.lemonadeday.org'>Lemonade Day McAllen</a></li>

<li class="future-event mc_concert"><strong><span class='mc_tb'>7:00 pm</span> <span>&ndash;</span> <span class='mc_te'>8:00 pm</span>, May 14, 2017</strong> – <a href='http://www.statefarmarena.com'>Miguel Bose</a></li>

<li class="future-event mc_general"><strong><span class='mc_tb'>12:00 pm</span> <span>&ndash;</span> <span class='mc_te'>1:00 pm</span>, May 15, 2017</strong> – <a href='http://www.salvationarmytexas.org/mcallen/'>Behind the Red Shield</a></li>

<li class="future-event mc_general"><strong><span class='mc_tb'>12:00 pm</span> <span>&ndash;</span> <span class='mc_te'>1:00 pm</span>, May 16, 2017</strong> – <a href='http://www.salvationarmytexas.org/mcallen/'>National Salvation Army Week- Feeding from the Canteen</a></li>
</ul></div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="tag_cloud-2" class="et_pb_widget widget_tag_cloud"><h4 class="widgettitle">Popular Tags</h4><div class="tagcloud"><a href='http://foxrio2.com/tag/accident/' class='tag-link-8041 tag-link-position-1' title='183 topics' style='font-size: 13.915492957746pt;'>accident</a>
<a href='http://foxrio2.com/tag/apple/' class='tag-link-16 tag-link-position-2' title='99 topics' style='font-size: 8.7887323943662pt;'>Apple</a>
<a href='http://foxrio2.com/tag/arrested/' class='tag-link-15268 tag-link-position-3' title='122 topics' style='font-size: 10.56338028169pt;'>arrested</a>
<a href='http://foxrio2.com/tag/border-patrol/' class='tag-link-324 tag-link-position-4' title='135 topics' style='font-size: 11.352112676056pt;'>border patrol</a>
<a href='http://foxrio2.com/tag/brownsville/' class='tag-link-193 tag-link-position-5' title='338 topics' style='font-size: 19.239436619718pt;'>Brownsville</a>
<a href='http://foxrio2.com/tag/cameron-county/' class='tag-link-621 tag-link-position-6' title='92 topics' style='font-size: 8.1971830985915pt;'>Cameron County</a>
<a href='http://foxrio2.com/tag/children/' class='tag-link-873 tag-link-position-7' title='262 topics' style='font-size: 17.070422535211pt;'>children</a>
<a href='http://foxrio2.com/tag/community/' class='tag-link-71 tag-link-position-8' title='229 topics' style='font-size: 15.887323943662pt;'>community</a>
<a href='http://foxrio2.com/tag/donna/' class='tag-link-1748 tag-link-position-9' title='147 topics' style='font-size: 12.140845070423pt;'>Donna</a>
<a href='http://foxrio2.com/tag/edinburg/' class='tag-link-348 tag-link-position-10' title='366 topics' style='font-size: 19.830985915493pt;'>Edinburg</a>
<a href='http://foxrio2.com/tag/facebook/' class='tag-link-826 tag-link-position-11' title='119 topics' style='font-size: 10.366197183099pt;'>Facebook</a>
<a href='http://foxrio2.com/tag/fire/' class='tag-link-5025 tag-link-position-12' title='220 topics' style='font-size: 15.492957746479pt;'>fire</a>
<a href='http://foxrio2.com/tag/government/' class='tag-link-1132 tag-link-position-13' title='186 topics' style='font-size: 14.112676056338pt;'>government</a>
<a href='http://foxrio2.com/tag/harlingen/' class='tag-link-396 tag-link-position-14' title='134 topics' style='font-size: 11.352112676056pt;'>Harlingen</a>
<a href='http://foxrio2.com/tag/hidalgo-county/' class='tag-link-312 tag-link-position-15' title='180 topics' style='font-size: 13.915492957746pt;'>Hidalgo County</a>
<a href='http://foxrio2.com/tag/immigrants/' class='tag-link-5842 tag-link-position-16' title='117 topics' style='font-size: 10.169014084507pt;'>immigrants</a>
<a href='http://foxrio2.com/tag/international/' class='tag-link-5898 tag-link-position-17' title='102 topics' style='font-size: 8.9859154929577pt;'>international</a>
<a href='http://foxrio2.com/tag/investigation/' class='tag-link-922 tag-link-position-18' title='430 topics' style='font-size: 21.211267605634pt;'>investigation</a>
<a href='http://foxrio2.com/tag/jobs/' class='tag-link-3313 tag-link-position-19' title='123 topics' style='font-size: 10.56338028169pt;'>jobs</a>
<a href='http://foxrio2.com/tag/marijuana/' class='tag-link-95 tag-link-position-20' title='118 topics' style='font-size: 10.366197183099pt;'>marijuana</a>
<a href='http://foxrio2.com/tag/mcallen/' class='tag-link-198 tag-link-position-21' title='357 topics' style='font-size: 19.633802816901pt;'>MCALLEN</a>
<a href='http://foxrio2.com/tag/mexico/' class='tag-link-760 tag-link-position-22' title='165 topics' style='font-size: 13.12676056338pt;'>Mexico</a>
<a href='http://foxrio2.com/tag/mission/' class='tag-link-1277 tag-link-position-23' title='247 topics' style='font-size: 16.478873239437pt;'>Mission</a>
<a href='http://foxrio2.com/tag/murder/' class='tag-link-9923 tag-link-position-24' title='94 topics' style='font-size: 8.3943661971831pt;'>murder</a>
<a href='http://foxrio2.com/tag/nasa/' class='tag-link-19 tag-link-position-25' title='114 topics' style='font-size: 9.9718309859155pt;'>NASA</a>
<a href='http://foxrio2.com/tag/nfl/' class='tag-link-433 tag-link-position-26' title='123 topics' style='font-size: 10.56338028169pt;'>NFL</a>
<a href='http://foxrio2.com/tag/officers/' class='tag-link-5511 tag-link-position-27' title='200 topics' style='font-size: 14.704225352113pt;'>officers</a>
<a href='http://foxrio2.com/tag/officials/' class='tag-link-5280 tag-link-position-28' title='175 topics' style='font-size: 13.718309859155pt;'>Officials</a>
<a href='http://foxrio2.com/tag/pharr/' class='tag-link-767 tag-link-position-29' title='175 topics' style='font-size: 13.718309859155pt;'>Pharr</a>
<a href='http://foxrio2.com/tag/president/' class='tag-link-5498 tag-link-position-30' title='158 topics' style='font-size: 12.732394366197pt;'>president</a>
<a href='http://foxrio2.com/tag/project/' class='tag-link-1423 tag-link-position-31' title='105 topics' style='font-size: 9.3802816901408pt;'>project</a>
<a href='http://foxrio2.com/tag/rgv/' class='tag-link-757 tag-link-position-32' title='98 topics' style='font-size: 8.7887323943662pt;'>RGV</a>
<a href='http://foxrio2.com/tag/rio-grande-valley/' class='tag-link-128 tag-link-position-33' title='112 topics' style='font-size: 9.7746478873239pt;'>Rio Grande Valley</a>
<a href='http://foxrio2.com/tag/robbery/' class='tag-link-5020 tag-link-position-34' title='102 topics' style='font-size: 8.9859154929577pt;'>Robbery</a>
<a href='http://foxrio2.com/tag/san-juan/' class='tag-link-202 tag-link-position-35' title='90 topics' style='font-size: 8pt;'>San Juan</a>
<a href='http://foxrio2.com/tag/south-padre-island/' class='tag-link-72 tag-link-position-36' title='95 topics' style='font-size: 8.3943661971831pt;'>South Padre Island</a>
<a href='http://foxrio2.com/tag/students/' class='tag-link-1381 tag-link-position-37' title='151 topics' style='font-size: 12.338028169014pt;'>students</a>
<a href='http://foxrio2.com/tag/suspects/' class='tag-link-201 tag-link-position-38' title='220 topics' style='font-size: 15.492957746479pt;'>suspects</a>
<a href='http://foxrio2.com/tag/technology-2/' class='tag-link-2422 tag-link-position-39' title='160 topics' style='font-size: 12.929577464789pt;'>technology</a>
<a href='http://foxrio2.com/tag/texas/' class='tag-link-37 tag-link-position-40' title='468 topics' style='font-size: 22pt;'>Texas</a>
<a href='http://foxrio2.com/tag/twitter/' class='tag-link-1084 tag-link-position-41' title='100 topics' style='font-size: 8.7887323943662pt;'>Twitter</a>
<a href='http://foxrio2.com/tag/united-states/' class='tag-link-6171 tag-link-position-42' title='108 topics' style='font-size: 9.5774647887324pt;'>United States</a>
<a href='http://foxrio2.com/tag/valley/' class='tag-link-1899 tag-link-position-43' title='240 topics' style='font-size: 16.281690140845pt;'>Valley</a>
<a href='http://foxrio2.com/tag/washington/' class='tag-link-106 tag-link-position-44' title='94 topics' style='font-size: 8.3943661971831pt;'>Washington</a>
<a href='http://foxrio2.com/tag/weslaco/' class='tag-link-48 tag-link-position-45' title='200 topics' style='font-size: 14.704225352113pt;'>Weslaco</a></div>
</div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
			<center>&copy; 2017 KFXV Entravision Communications Corporation<a href="//www.foxrio2.com/other-sites-of-interest/">.</a><br/> 801 N. Jackson, McAllen, TX 78501<br /></center>
    <div id="footer-nav">
     <ul id="footer-menu" class="bottom-nav">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.entravision.com/terms-of-use/">TERMS OF SERVICE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="//www.entravision.com/termsofsales/">Terms OF SALES</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.entravision.com/terms-of-use/#privacy">PRIVACY POLICY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://public.entravision.net/station/KNVO-EEO/">EEO</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="//www.foxrio2.com/about/contact/employment/">EMPLOYMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="//www.foxrio2.com/about/public-file/">ONLINE PUBLIC FILE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="//www.foxrio2.com/about/closed-captioning/">CLOSE CAPTIONING</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="//www.foxrio2.com/about/contactprogramming/">FEEDBACK</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://plus.google.com/u/0/b/117603024570539736963/+Foxrio2/posts" rel="publisher">Google+</a></li>
</ul>
</div>
    <span style="display:none;"><a href="https://www.cisneroslawfirm.com/"  title="Personal Injury Attorneys">Cisneros Law Firm</a></span>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-1036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1036"><a href="http://foxrio2.com/category/health/">Health</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="http://foxrio2.com/category/business/">Business</a></li>
<li id="menu-item-1035" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1035"><a href="http://foxrio2.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-1037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1037"><a href="http://foxrio2.com/category/home-improvement/">Home Improvement</a></li>
<li id="menu-item-1039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1039"><a href="http://foxrio2.com/category/special-reports/">Special Reports</a></li>
<li id="menu-item-1038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1038"><a href="http://foxrio2.com/category/science/">Science</a></li>
<li id="menu-item-1040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1040"><a href="http://foxrio2.com/category/technology/">Technology</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/rgvfox" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/rgvfox" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																									<li class="et-extra-social-icon googleplus">
								<a href="https://plus.google.com/u/0/b/117603024570539736963/+Foxrio2" class="et-extra-icon et-extra-icon-background-none et-extra-icon-googleplus"></a>
							</li>
																																																																																																																																																					<li class="et-extra-social-icon instagram">
								<a href="https://www.instagram.com/rgvfox/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	<!-- Begin Google api -->
<script type="text/javascript">
(function() {
    var po = document.createElement("script");
    po.type = "text/javascript";
    po.async = true;
    po.src = "https://apis.google.com/js/plusone.js?publisherid=117603024570539736963";
    var s = document.getElementsByTagName("script")[0];
    s.parentNode.insertBefore(po, s);
})();
</script>
<!-- End Google api -->

<noscript>
<div id='pm_tracker_i_140705613740'>
<img src='//t1.tentaculos.net/image/140705613740/_PM_STATUS,0/cb,1494731498' width='0' height='0' alt='tracker' />
</div> 
</noscript>
	<style type="text/css" id="et-builder-page-custom-style">
				 .et_pb_section { background-color: ; }
			</style><script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-53380916-1', 'auto');
  ga('send', 'pageview');

</script>
<!-- Background Ad -->
<div id="adz34607"></div>
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/139731_a.js"></script>

<!-- Splash Page -->
<div id="adz70449"></div>
<script data-cfasync="false" src="//c2.tentaculos.net/zonedata/330182/139733_a.js"></script><link rel='stylesheet' id='et-gf-abel-css'  href='http://fonts.googleapis.com/css?family=Abel:400&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='et-gf-droid-sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans:400,700&#038;subset=latin' type='text/css' media='all' />
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/frontend-builder-global-functions.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/wp-upg/js/jquery.colorbox-min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/blankshield/blankshield.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/block-tabnapping.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/scripts/ext/jquery.waypoints.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/scripts/ext/jquery.fitvids.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/scripts/ext/smoothscroll.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/masonry.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/salvattore.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"http:\/\/foxrio2.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"http:\/\/foxrio2.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"127618f6f1","timeline_nonce":"6ca532ea6b","blog_feed_nonce":"03f1f78740","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/scripts/scripts.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/scripts/ext/jquery.raty.min.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/jquery.fitvids.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/jquery.magnific-popup.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/jquery.mobile.custom.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"http:\/\/foxrio2.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/foxrio2.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"http:\/\/foxrio2.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"32be76ac86","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"3f0a16e7b5","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"51838","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://foxrio2.com/wp-content/themes/Extra/includes/builder/scripts/frontend-builder-scripts.js'></script>
<script type='text/javascript' src='http://foxrio2.com/wp-includes/js/wp-embed.min.js'></script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=27402049&postid=51838&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=wp_user_avatar&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=2e2285f75172523bfcee0c428caeb61e28d26068#parent=http%3A%2F%2Ffoxrio2.com%2Fthree-die-in-collision-in-raymondville-may-be-alcohol-related%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=27402049&postid=51838&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=wp_user_avatar&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=2e2285f75172523bfcee0c428caeb61e28d26068#parent=http%3A%2F%2Ffoxrio2.com%2Fthree-die-in-collision-in-raymondville-may-be-alcohol-related%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'27402049',post:'51838',tz:'-5',srv:'foxrio2.com'} ]);
	_stq.push([ 'clickTrackerInit', '27402049', '51838' ]);
</script>
<span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=hmi71j8K93U9N5I9JIGYsASosTwli9BdAcTgHXadiahDkCNb7VRTIsbOgGpE"></script></span>
</body>
</html>
